Ticket #103 (reopened issue)

Opened 7 years ago

Last modified 5 years ago

Setup online T-Shirt Shop

Reported by: ernie.prabhakar Owned by: zak
Priority: major Milestone: 2009 Q3
Component: Outreach Severity: board
Keywords: Cc: kfogel@…
Blocked By: Blocking:

Description (last modified by zak) (diff)

No worries. I'll add the issue to the board agenda and then punt it along at the next meeting as best I can.

p.s. Sorry for the twiddling of statuses on this issue - just sorting out how to best flag issues for board review. :)

Change History

Changed 7 years ago by ernie.prabhakar

  • owner changed from kencoar to ken.coar

Changed 6 years ago by coar

  • owner changed from ken.coar to coar
  • status changed from new to assigned

Changed 6 years ago by kfogel

Ken, action item for you (agreed to at Portland OSI meeting on 27 July 2008): send Danese a mail about where to ship the shirts she's currently storing.

Thanks!

-Karl

Changed 6 years ago by kfogel

  • cc kfogel@… added

Changed 5 years ago by zak

Ken,

Are you able to act on this item?

Do you wish to pass it on to someone else?

Changed 5 years ago by kfogel

I've had good experiences selling T-shirts using Amplifier.com, a fulfillment house based in Austin, TX. Basically, you send them all your stuff in bulk; they warehouse it and link up with an online store (usually done through Yahoo Stores, which Amplifier can set up), and then they handle all your orders, shipping, returns, basic customer service, etc.

This is assuming we want to sell online, of course.

For OSI, there's the question of whether an all-open-source solution is required, of course. I looked into some, and concluded that (for QuestionCopyright.org) the path of sanity was just to outsource this stuff and do what was easiest to work with Amplifier (thus we went with Yahoo Stores). Amplifier does have APIs, so it's not required to use Yahoo Stores, and there are open source shopping carts, some even for Drupal. So hooking that up with the fulfillment house would be just a "simple matter of programming". But I'm not sure it would be worth the effort. Shopping systems are a bear, credit card handling can be a bear, etc, and all this is a solved problem as SaS.

Anyway, for examples see:

 http://www.questioncopyright.com/shirtswomens.html  http://www.questioncopyright.com/shirtsmens.html

Happy to give more details if needed. I'm not sure if we're talking about just a place to store the shirts so they can be taken to conferences and such, or talking about actually selling them online.

Changed 5 years ago by kfogel

Interesting Trac bug: in the preview, those two URLs were on separate lines, as intended. But in the final rendered page, they are not. Go figure.

Changed 5 years ago by kfogel

Hah. I could just look at the title of this ticket: "Setup online T-shirt Shop". Guess that answers my question.

Well, then, Amplifier is a good way to go. If you want to talk to them (it should be someone at the OSI who has financial authority), I can give you their contact info.

Changed 5 years ago by zak

  • status changed from assigned to closed
  • resolution set to raise-motion
  • milestone set to 2009 Q3

Aloha Karl,

Thanks for the detailed info!

I'll raise this as an issue at the next board meeting (or, if you'll be there and want to raise the issue yourself, that'd be good. :) )

Changed 5 years ago by zak

  • status changed from closed to reopened
  • resolution raise-motion deleted

Changed 5 years ago by zak

  • owner changed from coar to zak
  • status changed from reopened to new

Changed 5 years ago by zak

  • status changed from new to closed
  • resolution set to raise-motion

Changed 5 years ago by kfogel

Hey, Zak. I may not be able to make it to the meeting (realtime scheduling is difficult right now); if I can't, I'm still happy to provide information and answer questions about setting up an online store, of course. It'd be a pity for all that hard-earned knowledge to go unused :-).

Changed 5 years ago by zak

  • status changed from closed to reopened
  • resolution raise-issue deleted
  • description modified (diff)
  • severity set to board
Note: See TracTickets for help on using tickets.